Selamlar dostlar,

Biliyoruz ki cpanel, ” EasyApache 4 ” ile multi php özelliğini kendi üzerinde zaten kullanıcılarına sundu. Bunun yanında kullanmakta olduğumuz cloudlinux içerisinde de gelen ” Alt-PHP ” özelliği bulunuyor. Bu durumda hem ” EasyApache 4 ” hemde ” CloudLinux ” kullananlar için son kullanıcı tarafında php sürümü seçilirken hep iki tarafında sürümleri listelenmektedir. WHM tarafında cloulinux için alt-php özelliği devre dışı bırakılabiliyor fakat sadece cpanel arayüzünden menüsü kalkmaktadır. Hep eski php sürümleri var ise hemde kullanıcıların kafalarını karıştırmamak adına aşağıdaki gibi alt-php seçenekleri disablel duruma getirebilirsiniz.

Adım 1 : Sunucumuza SSH bağlantısı yapıyoruz.

Adım 2 : nano /opt/alt/alt-php-config/alt-php.cfg

Komutu ile dosyamızı editör ile açıyoruz ve istemediğimiz php sürümlerini ” no ” ile değiştiriyoruz dilerseniz hepsini ” no ” yaparak sadece easyapache sürümlerini kullanıcılara seçtirebilirsiniz.

Adım 3 : Akabinde son adım olarak ” /opt/alt/alt-php-config/multiphp_reconfigure.py ” komutunu yürütüyoruz.

Adım 4 : Her şey bu kadar 🙂

Sağlıcakla kalın.